Redirect Issue - Login page and Calendar Links
Incident Report for FTA Services
Resolved
All calendar links and the login page are now available and fully functioning. You can access all FTA resources via www.taxadmin.org.
Posted Apr 12, 2017 - 18:41 EDT
Investigating
Due to an issue with our edge cache, the Login page and Calendar Links on www.taxadmin.org are not available.

To access the login page and calendar links, navigate to https://taxadmin.memberclicks.net in order to use our provider portal directly.
Posted Apr 12, 2017 - 12:21 EDT
This incident affected: TaxAdmin.org Platform.