One-Time Password Delivery
Incident Report for FTA Services
Resolved
Our provider has indicated that the earlier mentioned SMTP issues have been resolved. Please contact support@taxadmin.org if you are still experiencing issues receiving one-time passwords via email.
Posted Sep 27, 2016 - 11:56 EDT
Investigating
We have been notified by our provider that they are investigating reports of a slow SMTP connection to their servers. One-Time Password delivery may be affected while they work to resolve this issue.
Posted Sep 27, 2016 - 11:11 EDT
This incident affected: FTA State Exchange System.