Password Reset Request System Down
Incident Report for FTA Services
Resolved
This incident has been resolved.
Posted Aug 13, 2018 - 14:24 EDT
Identified
We're currently working with our provider to solve an issue with password reset request emails. If you request a password reset email from the main portal at https://taxadmin.kiteworks.com the appropriate email is failing to send. This does not impact new users or other email notifications from the system.
Posted Aug 13, 2018 - 11:45 EDT
This incident affected: FTA State Exchange System.