State Exchange System Email Delivery Disruption
Incident Report for FTA Services
Resolved
State Exchange email delivery has been restored. Users may log-in via the main portal at https://taxadmin.kiteworks.com.
Posted Oct 14, 2016 - 18:39 EDT
Update
We have isolated the issue and are working to resolve now. Thank you for your patience.
Posted Oct 14, 2016 - 18:25 EDT
Identified
We have confirmed an issue with delivery of State Exchange Emails. We are actively working to resolve this issue.
Posted Oct 14, 2016 - 16:28 EDT
Investigating
We are investigating reports that emails are not being generated for State Exchange accounts.
Posted Oct 14, 2016 - 16:12 EDT
This incident affected: FTA State Exchange System.