State Exchange System Portal Unavailable
Incident Report for FTA Services
Resolved
The FTA State Exchange System portal is operational. Please let us know if you experience any additional issues by emailing support@taxadmin.org.
Posted Dec 14, 2017 - 14:55 EST
Investigating
We are investigating reports of the State Exchange System portal being unavailable for sign-in. We'll post updates here.
Posted Dec 14, 2017 - 14:05 EST
This incident affected: FTA State Exchange System.